Bug #1019

Incorrect update notification

Added by Simon Dixon about 4 years ago. Updated over 3 years ago.

Status:ClosedStart date:2014-06-20
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

A message like "You are using 0.1 but 0.6 is available" appears at startup, although I pulled and built the latest version last night.

History

#1 Updated by Chris Cannam about 4 years ago

If you're building from source, the version.h file (which contains the version number, clearly 0.1 in your case) is only updated when you run the configure script. If you just make clean and make, it won't change. You could also edit it by hand of course.

This was originally a deliberate decision so that the version only needed to be updated in one place (the configure script). But it seems quite common that people don't run configure, e.g. for the Windows build it isn't used at all, so it probably does need to change.

#2 Updated by Chris Cannam over 3 years ago

  • Status changed from New to Closed

Also available in: Atom PDF