Bug #558

Impossible to use vertical toolbar when built with new Qt on OS/X 10.8

Added by Chris Cannam about 9 years ago. Updated almost 9 years ago.

Status:NewStart date:2012-12-11
Priority:UrgentDue date:
Assignee:Chris Cannam% Done:

0%

Category:-
Target version:1.3

Description

For some reason, the buttons in the vertical toolbar don't respond when easyhg is built with Qt 4.8 on OS/X 10.8. Investigating.


Related issues

Blocks Bug #527: Crash when merging branches New 2012-10-19

History

#1 Updated by Chris Cannam about 9 years ago

A lengthy git bisect on Qt ends with:

72aa2eb43b0cf5a6eef940da05ac58f605794ffb is the first bad commit
commit 72aa2eb43b0cf5a6eef940da05ac58f605794ffb
Author: Richard Moe Gustavsen <richard.gustavsen@nokia.com>
Date:   Thu Dec 9 14:10:57 2010 +0100

    Alien implementation for the Cocoa port

    Give Alien on Cocoa a warm welcome.

:040000 040000 626b955afeed54cef5c41bb3be62524d1be90f15 f3532a1f953dda7bab3922b2ce859ad45440c95e M    src
:040000 040000 367b63aae11d4cd5033360f9ecde83cdfe8cd70a 37913228896a8a269e43fab565ce15b93cc5ca03 M    tests

which unfortunately is a huge merge commit, so this doesn't get us a great deal further.

#2 Updated by Chris Cannam about 9 years ago

Tested with Qt5 to see if it was fixed there -- and there is no blimmin' unified toolbar support in Qt5! It always uses separate-toolbar mode.

Which works, but is ugly. Gah!

#3 Updated by Chris Cannam almost 9 years ago

  • Target version set to 1.3

Also available in: Atom PDF