Bug #1904

Scrolling colour 3d plot does not always work when in View normalisation mode

Added by Chris Cannam 4 months ago. Updated 2 months ago.

Status:ClosedStart date:2019-08-12
Priority:HighDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

In some circumstances (to be established!) the colour 3d plot layer refuses to scroll when View normalisation is selected. The displayed image remains unchanged regardless of how much you drag left or right.

The log file contains many lines of this form

[12671] render: just invalidated cache in time-constrained context, that's all we're doing for now - wait for next update to start filling
[12671] Colour3DPlotLayer: rebuilding renderer, value range is 0.995137 -> 1.0008 (model min = 0.995137, max = 1.0008)
[12671] render: just invalidated cache in time-constrained context, that's all we're doing for now - wait for next update to start filling
[12671] Colour3DPlotLayer: rebuilding renderer, value range is 0.995137 -> 1.0008 (model min = 0.995137, max = 1.0008)
[12671] render: just invalidated cache in time-constrained context, that's all we're doing for now - wait for next update to start filling
[12671] Colour3DPlotLayer: rebuilding renderer, value range is 0.995137 -> 1.0008 (model min = 0.995137, max = 1.0008)
[12671] render: just invalidated cache in time-constrained context, that's all we're doing for now - wait for next update to start filling
[12671] Colour3DPlotLayer: rebuilding renderer, value range is 0.995137 -> 1.0008 (model min = 0.995137, max = 1.0008)

History

#1 Updated by Chris Cannam 2 months ago

  • Status changed from New to Closed

Fixed in 62d6e9ad19f4

Also available in: Atom PDF