diff configure.ac @ 278:bdedb6114fc6

* Fix to prior commit
author cannam
date Thu, 12 Feb 2009 12:12:57 +0000
parents 6d355f1b7eaf
children ebc47e614cf5
line wrap: on
line diff
--- a/configure.ac	Thu Feb 12 12:01:58 2009 +0000
+++ b/configure.ac	Thu Feb 12 12:12:57 2009 +0000
@@ -22,8 +22,7 @@
 
 dnl if the user wants progs, then we need to check for libsndfile
 if test "x$PROGS_ARGUMENT" = "xyes" ; then 
-	PKG_CHECK_MODULES([SNDFILE],[sndfile], 
-					  have_sndfile="yes", have_sndfile="no")
+	PKG_CHECK_MODULES([SNDFILE],[sndfile],have_sndfile="yes",have_sndfile="no")
 	if test "x$have_sndfile" = "xyes" ; then
 		dnl all good, build everything
 		TARGETS="sdk plugins host rdfgen test"
@@ -38,6 +37,7 @@
 
 AC_SUBST(SNDFILE_CFLAGS)
 AC_SUBST(SNDFILE_LIBS)
+AC_SUBST(TARGETS)
 
 changequote(,)dnl
 if test "x$GCC" = "xyes"; then
@@ -48,5 +48,6 @@
 fi
 changequote([,])dnl
 
+AC_SUBST(CXXFLAGS)
 AC_OUTPUT([Makefile])