diff configure.ac @ 579:b716527bb0c9

* Update config per recent changes to svcore
author Chris Cannam
date Tue, 08 Mar 2011 11:28:53 +0000
parents 462e4f59c261
children 6948c3cc151e
line wrap: on
line diff
--- a/configure.ac	Mon Feb 07 21:07:47 2011 +0000
+++ b/configure.ac	Tue Mar 08 11:28:53 2011 +0000
@@ -11,6 +11,13 @@
 # piddling about.
 USER_CXXFLAGS="$CXXFLAGS"
 
+# If the user supplied CFLAGS but not CXXFLAGS, use CFLAGS instead
+if test x"$USER_CXXFLAGS" = x; then
+   if test x"$CFLAGS" != x; then
+      USER_CXXFLAGS="$CFLAGS"
+   fi
+fi
+
 AC_LANG_CPLUSPLUS
 
 AC_PROG_CC