diff view/Pane.h @ 1537:4f8c72adbf43

Clarify naming of some view-related methods. Rename LayerGeometryProvider::getValueExtents to getVisibleExtentsForUnit, and View::getTextLabelHeight to getTextLabelYCoord. Add View::getVisibleExtentsForAnyUnit to be used to determine which unit to adopt in a new e.g. box layer.
author Chris Cannam
date Tue, 15 Oct 2019 11:40:56 +0100
parents 235e08aa2d5d
children 0f36e0eca6b0
line wrap: on
line diff
--- a/view/Pane.h	Tue Oct 15 09:32:24 2019 +0100
+++ b/view/Pane.h	Tue Oct 15 11:40:56 2019 +0100
@@ -106,10 +106,6 @@
     void mouseEnteredWidget();
     void mouseLeftWidget();
 
-    bool getTopLayerDisplayExtents(double &valueMin, double &valueMax,
-                                   double &displayMin, double &displayMax,
-                                   QString *unit = 0);
-
 protected slots:
     void playbackScheduleTimerElapsed();
 
@@ -154,6 +150,9 @@
 
     bool canTopLayerMoveVertical();
     bool setTopLayerDisplayExtents(double displayMin, double displayMax);
+    bool getTopLayerDisplayExtents(double &valueMin, double &valueMax,
+                                   double &displayMin, double &displayMax,
+                                   QString *unit = 0);
 
     void dragTopLayer(QMouseEvent *e);
     void dragExtendSelection(QMouseEvent *e);