diff layer/Layer.cpp @ 1537:4f8c72adbf43

Clarify naming of some view-related methods. Rename LayerGeometryProvider::getValueExtents to getVisibleExtentsForUnit, and View::getTextLabelHeight to getTextLabelYCoord. Add View::getVisibleExtentsForAnyUnit to be used to determine which unit to adopt in a new e.g. box layer.
author Chris Cannam
date Tue, 15 Oct 2019 11:40:56 +0100
parents b402121d8f5f
children 073ef72e8e60
line wrap: on
line diff
--- a/layer/Layer.cpp	Tue Oct 15 09:32:24 2019 +0100
+++ b/layer/Layer.cpp	Tue Oct 15 11:40:56 2019 +0100
@@ -630,7 +630,7 @@
         return false;
     }
 
-    if (!v->getValueExtents(unit, min, max, logarithmic)) {
+    if (!v->getVisibleExtentsForUnit(unit, min, max, logarithmic)) {
         return false;
     }