diff layer/BoxLayer.cpp @ 1537:4f8c72adbf43

Clarify naming of some view-related methods. Rename LayerGeometryProvider::getValueExtents to getVisibleExtentsForUnit, and View::getTextLabelHeight to getTextLabelYCoord. Add View::getVisibleExtentsForAnyUnit to be used to determine which unit to adopt in a new e.g. box layer.
author Chris Cannam
date Tue, 15 Oct 2019 11:40:56 +0100
parents 873ff035364c
children ec837d223bd9
line wrap: on
line diff
--- a/layer/BoxLayer.cpp	Tue Oct 15 09:32:24 2019 +0100
+++ b/layer/BoxLayer.cpp	Tue Oct 15 11:40:56 2019 +0100
@@ -472,7 +472,7 @@
 
     if (m_verticalScale == AutoAlignScale) {
 
-        if (!v->getValueExtents(queryUnits, min, max, log)) {
+        if (!v->getVisibleExtentsForUnit(queryUnits, min, max, log)) {
 
             min = model->getValueMinimum();
             max = model->getValueMaximum();