comparison layer/Layer.cpp @ 1537:4f8c72adbf43

Clarify naming of some view-related methods. Rename LayerGeometryProvider::getValueExtents to getVisibleExtentsForUnit, and View::getTextLabelHeight to getTextLabelYCoord. Add View::getVisibleExtentsForAnyUnit to be used to determine which unit to adopt in a new e.g. box layer.
author Chris Cannam
date Tue, 15 Oct 2019 11:40:56 +0100
parents b402121d8f5f
children 073ef72e8e60
comparison
equal deleted inserted replaced
1536:5a215033b853 1537:4f8c72adbf43
628 628
629 if (!getValueExtents(min_, max_, logarithmic_, unit)) { 629 if (!getValueExtents(min_, max_, logarithmic_, unit)) {
630 return false; 630 return false;
631 } 631 }
632 632
633 if (!v->getValueExtents(unit, min, max, logarithmic)) { 633 if (!v->getVisibleExtentsForUnit(unit, min, max, logarithmic)) {
634 return false; 634 return false;
635 } 635 }
636 636
637 if (min != min_ || 637 if (min != min_ ||
638 max != max_ || 638 max != max_ ||