2008-01-04 |
Chris Cannam |
* better progress reporting in FileSource
|
2007-12-17 |
Chris Cannam |
* fix support for logarithmic hints in plugin parameters
|
2007-12-13 |
Chris Cannam |
* Fix #1841095 tapping time instant gives wrong time in aligned track
|
2007-12-11 |
Chris Cannam |
* Make font size in panes configurable, with a smaller default
|
2007-12-10 |
Chris Cannam |
* more handy functions
|
2007-12-10 |
Chris Cannam |
...
|
2007-12-10 |
Chris Cannam |
* Add public TransformFactory::instantiatePluginFor()
|
2007-12-07 |
Chris Cannam |
* Merge from transforms branch -- switch over to using Transform object
|
2007-11-30 |
Chris Cannam |
* Merge r884 from trunk
1.2-stable
|
2007-11-30 |
Chris Cannam |
* Skip ID3 block when reading MP3 files (so long as ID3 support is included)
|
2007-11-29 |
Chris Cannam |
* merge fixes from trunk
1.2-stable
|
2007-11-29 |
Chris Cannam |
* Attempt to fix finding of file:/// URLs
|
2007-11-28 |
Chris Cannam |
* Improvements to layer summary dialog (LayerTree, LayerTreeDialog), & rename.
|
2007-11-28 |
Chris Cannam |
* Fix idiotic bug in previous commit
|
2007-11-28 |
Chris Cannam |
* Try to ensure alignment works correctly with MATCH plugin v1 as well as v2
|
2007-11-26 |
Chris Cannam |
* Fixes for handling of DOS paths (C:\blah) -- not an unknown URL scheme!
|
2007-11-26 |
Chris Cannam |
* Fix log range mapper bug
|
2007-11-23 |
Chris Cannam |
* Add Erase tool and mode
|
2007-11-22 |
Chris Cannam |
* Some work on correct alignment when moving panes during playback
|
2007-11-22 |
Chris Cannam |
* More space and time efficient AlignmentModel
|
2007-11-15 |
Chris Cannam |
* Merge last fix from trunk
spectrogram-cache-rejig
|
2007-11-15 |
Chris Cannam |
* Fix mishandling of encoded urls
|
2007-11-13 |
Chris Cannam |
* Get storage advice for each cache in an FFT data server. Allows us to be
spectrogram-cache-rejig
|
2007-11-11 |
Chris Cannam |
* Pass StorageAdviser::Criteria into FFTModel constructor etc
|
2007-11-09 |
Chris Cannam |
* Factor out uses of "Sonic Visualiser" in "common" code to applicationName()
|
2007-11-07 |
Chris Cannam |
* some tidying, and put some actual work in TransformFactory
|
2007-11-07 |
Chris Cannam |
* Further naming change: Transformer -> ModelTransformer.
|
2007-11-06 |
Chris Cannam |
* Another incremental update (this class not yet used)
|