comparison transform/TransformFactory.h @ 18:4563a72c1d8b

* Add Zero Crossings output from zc plugin (as well as Zero Crossings Count) * Use brief friendly names for layers instead of full transform descriptions * Clearer command names for editing commands * Some efficiencies in drawing dense points in TimeInstantLayer
author Chris Cannam
date Tue, 31 Jan 2006 17:19:45 +0000
parents cc98d496d52b
children bac8b14ab355
comparison
equal deleted inserted replaced
17:2fb933f88604 18:4563a72c1d8b
50 * The returned model is owned by the caller and must be deleted 50 * The returned model is owned by the caller and must be deleted
51 * when no longer needed. 51 * when no longer needed.
52 */ 52 */
53 Model *transform(TransformName name, Model *inputModel); 53 Model *transform(TransformName name, Model *inputModel);
54 54
55 /**
56 * Full description of a transform, suitable for putting on a menu.
57 */
55 QString getTransformDescription(TransformName name); 58 QString getTransformDescription(TransformName name);
59
60 /**
61 * Brief but friendly description of a transform, suitable for use
62 * as the name of the output layer.
63 */
64 QString getTransformFriendlyName(TransformName name);
56 65
57 //!!! Need some way to indicate that the input model has changed / 66 //!!! Need some way to indicate that the input model has changed /
58 //been deleted so as not to blow up backgrounded transform! -- Or 67 //been deleted so as not to blow up backgrounded transform! -- Or
59 //indeed, if the output model has been deleted -- could equally 68 //indeed, if the output model has been deleted -- could equally
60 //well happen! 69 //well happen!