diff configure.ac @ 216:ee31e2f3a0f1

* Update config per recent changes to svcore
author Chris Cannam
date Tue, 08 Mar 2011 11:31:24 +0000
parents 70b2681665a7
children 819fd4147acf
line wrap: on
line diff
--- a/configure.ac	Fri Feb 04 14:31:33 2011 +0000
+++ b/configure.ac	Tue Mar 08 11:31:24 2011 +0000
@@ -11,6 +11,13 @@
 # piddling about.
 USER_CXXFLAGS="$CXXFLAGS"
 
+# If the user supplied CFLAGS but not CXXFLAGS, use CFLAGS instead
+if test x"$USER_CXXFLAGS" = x; then
+   if test x"$CFLAGS" != x; then
+      USER_CXXFLAGS="$CFLAGS"
+   fi
+fi
+
 AC_LANG_CPLUSPLUS
 
 AC_PROG_CC