diff src/portaudio_20161030_catalina_patch/configure.in @ 81:7029a4916348

Merge build update
author Chris Cannam
date Thu, 31 Oct 2019 13:36:58 +0000
parents 91c729825bca
children
line wrap: on
line diff
--- a/src/portaudio_20161030_catalina_patch/configure.in	Thu Oct 31 13:20:41 2019 +0000
+++ b/src/portaudio_20161030_catalina_patch/configure.in	Thu Oct 31 13:36:58 2019 +0000
@@ -203,8 +203,9 @@
         dnl Mac OS X configuration
 
         AC_DEFINE(PA_USE_COREAUDIO,1)
+        AC_DEFINE(AUDIO_COMPONENT_FIX,1)
 
-        CFLAGS="$CFLAGS -I\$(top_srcdir)/src/os/unix -Wno-deprecated -Werror"
+        CFLAGS="$CFLAGS -I\$(top_srcdir)/src/os/unix -Wno-deprecated"
         LIBS="-framework CoreAudio -framework AudioToolbox -framework AudioUnit -framework Carbon"
 
         if test "x$enable_mac_universal" = "xyes" ; then
@@ -258,15 +259,21 @@
               elif xcodebuild -version -sdk macosx10.12 Path >/dev/null 2>&1 ; then
                  mac_version_min="-mmacosx-version-min=10.4"
                  mac_sysroot="-isysroot `xcodebuild -version -sdk macosx10.12 Path`"
+              elif xcodebuild -version -sdk macosx10.13 Path >/dev/null 2>&1 ; then
+                 mac_version_min="-mmacosx-version-min=10.4"
+                 mac_sysroot="-isysroot `xcodebuild -version -sdk macosx10.13 Path`"
+              elif xcodebuild -version -sdk macosx10.14 Path >/dev/null 2>&1 ; then
+                 mac_version_min="-mmacosx-version-min=10.4"
+                 mac_sysroot="-isysroot `xcodebuild -version -sdk macosx10.14 Path`"
               else
-                 AC_MSG_ERROR([Could not find 10.5 to 10.12 SDK.])
+                 AC_MSG_ERROR([Could not find 10.5 to 10.14 SDK.])
               fi
            esac
 
            dnl Pick which architectures to build for based on what
            dnl the compiler supports.
            mac_arches=""
-           for arch in i386 x86_64 ppc ppc64
+           for arch in x86_64 
            do
               save_CFLAGS="$CFLAGS"
               CFLAGS="$CFLAGS -arch $arch"