diff src/libsndfile-1.0.25/Makefile.am @ 85:545efbb81310

Import initial set of sources
author Chris Cannam <cannam@all-day-breakfast.com>
date Mon, 18 Mar 2013 14:12:14 +0000
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/src/libsndfile-1.0.25/Makefile.am	Mon Mar 18 14:12:14 2013 +0000
@@ -0,0 +1,41 @@
+## Process this file with automake to produce Makefile.in
+
+DISTCHECK_CONFIGURE_FLAGS = --enable-gcc-werror
+
+if BUILD_OCTAVE_MOD
+octave_dir = Octave
+endif
+
+SUBDIRS = M4 man doc Win32 src $(octave_dir) examples regtest tests programs
+DIST_SUBDIRS = M4 man doc Win32 src Octave examples regtest tests programs
+
+EXTRA_DIST = libsndfile.spec.in sndfile.pc.in
+
+CLEANFILES = *~
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = sndfile.pc
+
+m4datadir = $(datadir)/aclocal
+
+#===============================================================================
+
+test: check-recursive
+
+# Target to make autogenerated files.
+genfiles :
+	(cd src ; make genfiles)
+	(cd tests ; make genfiles)
+
+checkprograms :
+	(cd src ; make libsndfile.la checkprograms)
+	(cd tests ; make checkprograms)
+
+testprogs :
+	(cd src ; make testprogs)
+	(cd tests ; make testprogs)
+
+
+test-tarball : build-test-tarball.mk
+	make all
+	make -f build-test-tarball.mk