diff configure.ac @ 884:93a770ecfc98 cxx11

CXX11 (-std=c++11) branch, to test build environments before making any code adaptations
author Chris Cannam
date Mon, 17 Nov 2014 15:31:08 +0000
parents 5462ac97d28f
children b40f29144e80 a16456ca5e71
line wrap: on
line diff
--- a/configure.ac	Mon Nov 10 09:54:09 2014 +0000
+++ b/configure.ac	Mon Nov 17 15:31:08 2014 +0000
@@ -1,5 +1,5 @@
 
-AC_INIT([Sonic Visualiser], [2.4], cannam@all-day-breakfast.com)
+AC_INIT([Sonic Visualiser], [2.4.1], cannam@all-day-breakfast.com)
 
 AC_CONFIG_SRCDIR(main/main.cpp)
 
@@ -25,6 +25,9 @@
 AC_PROG_INSTALL
 AC_PROG_MKDIR_P
 
+# We are daringly making use of C++11 now
+AX_CXX_COMPILE_STDCXX_11(noext)
+
 AC_HEADER_STDC
 
 # These are the flags Autoconf guesses for us; we use them later if
@@ -50,9 +53,9 @@
 CXXFLAGS_MINIMAL="$AUTOCONF_CXXFLAGS"
 
 if test "x$GCC" = "xyes"; then
-        CXXFLAGS_DEBUG="-Wall -Wextra -Werror -Woverloaded-virtual -Wformat-nonliteral -Wformat-security -Winit-self -Wswitch-enum -g -pipe"
-   	CXXFLAGS_RELEASE="-g0 -O2 -Wall -pipe"
-   	CXXFLAGS_MINIMAL="-g0 -O0"
+        CXXFLAGS_DEBUG="-std=c++11 -Wall -Wextra -Werror -Woverloaded-virtual -Wformat-nonliteral -Wformat-security -Winit-self -Wswitch-enum -g -pipe"
+   	CXXFLAGS_RELEASE="-std=c++11 -g0 -O2 -Wall -pipe"
+   	CXXFLAGS_MINIMAL="-std=c++11 -g0 -O0"
 fi
 
 CXXFLAGS_BUILD="$CXXFLAGS_RELEASE"