diff configure.ac @ 1969:714f8dad57bc c++14

Switch experimentally to C++14 throughout
author Chris Cannam
date Fri, 31 Aug 2018 10:02:48 +0100
parents adc8a48f4e4c
children 810a0b8f5472
line wrap: on
line diff
--- a/configure.ac	Tue Aug 14 09:43:28 2018 +0100
+++ b/configure.ac	Fri Aug 31 10:02:48 2018 +0100
@@ -53,7 +53,7 @@
 CXXFLAGS_MINIMAL="$AUTOCONF_CXXFLAGS"
 
 if test "x$GCC" = "xyes"; then
-   	CXXFLAGS_ANY="-std=c++11 -fpic -Wall -Wextra -Woverloaded-virtual -Wformat-nonliteral -Wformat-security -Winit-self -Wswitch-enum -Wconversion -pipe"
+   	CXXFLAGS_ANY="-fpic -Wall -Wextra -Woverloaded-virtual -Wformat-nonliteral -Wformat-security -Winit-self -Wswitch-enum -Wconversion -pipe"
         CXXFLAGS_DEBUG="$CXXFLAGS_ANY -g -O2 -Werror"
    	CXXFLAGS_RELEASE="$CXXFLAGS_ANY -g0 -O3 -ffast-math"
    	CXXFLAGS_MINIMAL="$CXXFLAGS_ANY -g0 -O0"