diff configure.ac @ 1709:41a64dc57066 vext

Update Vext logic
author Chris Cannam
date Wed, 07 Jun 2017 10:05:47 +0100
parents a4da817dc221
children e4cf3ec06955
line wrap: on
line diff
--- a/configure.ac	Wed Jun 07 09:56:57 2017 +0100
+++ b/configure.ac	Wed Jun 07 10:05:47 2017 +0100
@@ -139,11 +139,24 @@
 
 AC_OUTPUT
 
-if test -d .hg ; then 
-   if ! ./vext install; then
-      AC_MSG_ERROR([Vext failed; please fix any reported errors and try again])
+if test -x vext ; then
+   if test -d .hg -o -d .git ; then 
+      if ! ./vext install; then
+         AC_MSG_ERROR([Vext failed; please fix any reported errors and try again])
+      fi
+   else
+      AC_MSG_NOTICE([Vext executable found but not in an Hg or Git working-copy: not running it])
+      if ! test -d vamp-plugin-sdk ; then
+          AC_MSG_WARN([No vamp-plugin-sdk directory present, so external libraries might not have been updated])
+      fi
+   fi
+else
+   AC_MSG_NOTICE([No Vext executable found: assuming external libraries are already here])
+   if ! test -d vamp-plugin-sdk ; then
+      AC_MSG_WARN([No vamp-plugin-sdk directory present, so external libraries might not have been updated])
    fi
 fi
+
 if ! $QMAKE -r sonic-visualiser.pro; then
    AC_MSG_ERROR([qmake failed: Command was "$QMAKE -r"])
 fi