diff configure.ac @ 48:f0e3651ad3b0

* Update config per recent changes to svcore
author Chris Cannam
date Tue, 08 Mar 2011 11:36:13 +0000
parents 4d07f61dba3f
children 3840c55c75c2
line wrap: on
line diff
--- a/configure.ac	Wed Mar 02 15:27:21 2011 +0000
+++ b/configure.ac	Tue Mar 08 11:36:13 2011 +0000
@@ -11,6 +11,13 @@
 # piddling about.
 USER_CXXFLAGS="$CXXFLAGS"
 
+# If the user supplied CFLAGS but not CXXFLAGS, use CFLAGS instead
+if test x"$USER_CXXFLAGS" = x; then
+   if test x"$CFLAGS" != x; then
+      USER_CXXFLAGS="$CFLAGS"
+   fi
+fi
+
 AC_LANG_CPLUSPLUS
 
 AC_PROG_CC