diff configure.ac @ 138:ee56e3e9eeb5

Add -Werror in debug mode, and fix errors resulting from it
author Chris Cannam
date Mon, 13 Oct 2014 11:42:54 +0100
parents 5fe1f2efd407
children 795d67a5e266
line wrap: on
line diff
--- a/configure.ac	Mon Oct 13 10:16:37 2014 +0100
+++ b/configure.ac	Mon Oct 13 11:42:54 2014 +0100
@@ -1,5 +1,5 @@
 
-AC_INIT([Sonic Annotator], [1.0], cannam@all-day-breakfast.com)
+AC_INIT([Sonic Annotator], [1.1-hg], cannam@all-day-breakfast.com)
 
 AC_CONFIG_SRCDIR(runner/main.cpp)
 
@@ -50,7 +50,7 @@
 CXXFLAGS_MINIMAL="$AUTOCONF_CXXFLAGS"
 
 if test "x$GCC" = "xyes"; then
-        CXXFLAGS_DEBUG="-Wall -Woverloaded-virtual -Wextra -Wformat-nonliteral -Wformat-security -Winit-self -Wswitch-enum -g -pipe"
+        CXXFLAGS_DEBUG="-Wall -Werror -Woverloaded-virtual -Wextra -Wformat-nonliteral -Wformat-security -Winit-self -Wswitch-enum -g -pipe"
    	CXXFLAGS_RELEASE="-g0 -O2 -Wall -pipe"
    	CXXFLAGS_MINIMAL="-g0 -O0"
 fi