diff hgexpwidget.h @ 92:06f4fffd5287

* Rename StatParser to FileStates; start thinking about selections
author Chris Cannam
date Wed, 24 Nov 2010 13:23:30 +0000
parents 879af4608c5e
children 44ed7766d55a
line wrap: on
line diff
--- a/hgexpwidget.h	Tue Nov 23 21:04:02 2010 +0000
+++ b/hgexpwidget.h	Wed Nov 24 13:23:30 2010 +0000
@@ -20,7 +20,7 @@
 
 #include "changeset.h"
 #include "common.h"
-#include "statparser.h"
+#include "filestates.h"
 
 #include <QMenu>
 #include <QListWidget>
@@ -47,10 +47,12 @@
     void updateLocalRepoHgLogList(QString hgLogList);
     void setWorkFolderAndRepoNames(QString workFolderPath, QString remoteRepoPath);
 
-    //!!! StatParser really should be renamed to express "status state" rather than activity
-    StatParser getStatParser() { return statParser; }
+    FileStates getFileStates() { return fileStates; }
 
     bool canCommit() const;
+    bool canAdd() const;
+    bool canRemove() const;
+    bool canDoFolderDiff() const;
 
 private:
     FileStatusWidget *fileStatusWidget;
@@ -60,7 +62,7 @@
     QWidget *historyGraphPanner;
     QWidget *historyPageWidget;
 
-    StatParser statParser;
+    FileStates fileStates;
 
     Changesets parseChangeSets(QString changeSetsStr);
 };