diff toolboxes/_python_lib/pylast/setup.py @ 0:e9a9cd732c1e tip

first hg version after svn
author wolffd
date Tue, 10 Feb 2015 15:05:51 +0000
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/toolboxes/_python_lib/pylast/setup.py	Tue Feb 10 15:05:51 2015 +0000
@@ -0,0 +1,32 @@
+#!/usr/bin/env python
+
+from distutils.core import setup
+
+import os
+def get_build():
+	path = "./.build"
+	
+	if os.path.exists(path):
+		fp = open(path, "r")
+		build = eval(fp.read())
+		if os.path.exists("./.increase_build"):
+			build += 1
+		fp.close()
+	else:
+		build = 1
+	
+	fp = open(path, "w")
+	fp.write(str(build))
+	fp.close()
+	
+	return str(build)
+
+setup(name = "pylast",
+      version = "0.5." + get_build(),
+      author = "Amr Hassan <amr.hassan@gmail.com>",
+	  description = "A Python interface to Last.fm (and other API compatible social networks)",
+      author_email = "amr.hassan@gmail.com",
+      url = "http://code.google.com/p/pylast/",
+      py_modules = ("pylast",),
+	  license = "Apache2"
+	)