diff python-module/setup.py @ 46:af7739411685

Added all source code
author Adam Stark <adamstark@users.noreply.github.com>
date Tue, 21 Jan 2014 00:10:11 +0000
parents
children 46971d477183
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/python-module/setup.py	Tue Jan 21 00:10:11 2014 +0000
@@ -0,0 +1,16 @@
+# setup.py
+# build command : python setup.py build build_ext --inplace
+from numpy.distutils.core import setup, Extension
+import os, numpy
+
+name = 'btrack'
+sources = ['btrack_python_module.cpp','../src/OnsetDetectionFunction.cpp','../src/BTrack.cpp']
+
+include_dirs = [
+                numpy.get_include(),'/usr/local/include'
+                ]
+
+setup( name = 'BTtrack',
+      include_dirs = include_dirs,
+      ext_modules = [Extension(name, sources,libraries = ['fftw3','samplerate'])]
+      )
\ No newline at end of file